Problem about install isce-2.2.0

Added by Yahui Chong about 1 month ago

Dear all,
I want to install isce-2.2.0 on Ubuntu 18.04, when I running the "scons install", I meet some errors as follows:

yh@cyh-MS-7673:/usr/local/isce-2.2.0$ scons install
scons: Reading SConscript files ...
Building with scons from python2
Checking for C header file Python.h... yes
Checking for C header file fftw3.h... yes
Checking for C header file hdf5.h... yes
Checking for C header file X11/Xlib.h... yes
Checking for C header file Xm/Xm.h... yes
Checking for C header file omp.h... yes
Checking for C library hdf5... yes
Checking for C library fftw3f... yes
Checking for C library Xm... yes
Checking for C library Xt... yes
Checking for F include fftw3 ... yes
GDAL version: 2.4.0

Checking for C++ header file gdal_priv.h... yes
Checking for C library gdal... yes
Scons appears to find everything needed for installation
User did not request CUDA support. Add ENABLE_CUDA = True to SConfigISCE to enable CUDA support
Building with scons from python2
Checking for F include fftw3 ... yes
GDAL version: 2.4.0

Scons appears to find everything needed for installation
User did not request CUDA support. Add ENABLE_CUDA = True to SConfigISCE to enable CUDA support
No module named 'iscesys'
No module named 'iscesys'
No module named 'isceobj'
KeyError: 'MOTIFINCPATH':
File "/usr/local/isce-2.2.0/SConstruct", line 258:
SConscript(contrib)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 614:
return method(*args, **kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 551:
return SConscript(self.fs, *files, **subst_kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 260:
exec _file
in call_stack[-1].globals
File "/usr/local/isce-2.2.0/contrib/SConscript", line 58:
SConscript(mdx)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 614:
return method(*args, **kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 551:
return SConscript(self.fs, *files, **subst_kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 260:
exec _file
in call_stack[-1].globals
File "/usr/local/isce-2.2.0/contrib/mdx/SConscript", line 40:
SConscript(src,variant_dir=os.path.join(build,'src'))
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 614:
return method(*args, **kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 551:
return SConscript(self.fs, *files, **subst_kw)
File "/usr/local/lib/scons-2.0.1/SCons/Script/SConscript.py", line 260:
exec _file
in call_stack[-1].globals
File "/usr/local/isce-2.2.0/build/isce/components/contrib/mdx/src/SConscript", line 23:
envmdx.Append( CCFLAGS=['-DSUN','-DIO64','-I'+envmdx['MOTIFINCPATH'],'-I'+envmdx['X11INCPATH']] )
File "/usr/local/lib/scons-2.0.1/SCons/Environment.py", line 409:
return self._dict[key]
scons: done reading SConscript files.
scons: Building targets ...
Install file: "__init__.py" as "install/isce/__init__.py"
scons: done building targets.

Does anyone know how to solve this problem? Thank you very much!


Replies (3)

RE: Problem about install isce-2.2.0 - Added by Piyush Agram about 1 month ago

Sorry. isce-2.2.0 is ancient and I dont think you will find volunteers to support this.
Please note that people provide support voluntarily and we only have energy and spare time to support the latest versions.

RE: Problem about install isce-2.2.0 - Added by Yahui Chong about 1 month ago

Hi Piyush,
Thank you very much for your reply! I have installed isce-2.4.0 successfully, but T wonder if ISCE-2.4.0 has all the functions of ISCE-2.2.0?

(1-3/3)