No module named 'isce'

Added by Sven Borgstrom over 5 years ago

Dear ISCE developers,
we made an installation using the SConfigISCE file for Ubuntu 14.04 we found on the forum related to the answer of "Error at Snaphu build stage" on May 26.
The installation was ok but, trying to process a CSK pair, we got the error message of No module named 'isce' (see No_module_isce.png), although isce is regularly installed (see module_version.png, moreover we don't get the indication of the isce version, in the same png file).
Maybe the issue is related to the wrong PATH/PYTHONPATH (see PATH_PYTHONPATH.png)?
Cheers,
Sven.


Replies (6)

RE: No module named 'isce' - Added by Piyush Agram over 5 years ago

Hi Sven,
You do not need all those directories on your PYTHONPATH. You need the "PRJ_SCONS_INSTALL" variable to end in a directory named "isce".

In my case, I have the software installed under "/Users/agram/tools/ISCE3_latest/install/isce" and my corresponding path variables are as follows.

$echo PRJ_SCONS_INSTALL
/Users/agram/tools/ISCE3_latest/install/isce

$ echo $PYTHONPATH
/Users/agram/tools/ISCE3_latest/install

$echo $PATH
/Users/agram/tools/ISCE3_latest/install/isce/bin:/Users/agram/tools/ISCE3_latest/install/isce/applications

Piyush

RE: No module named 'isce' - Added by Andreas Steinberg over 4 years ago

Hello all,

i have the same trouble of No module named 'isce'. ISCE installed and compiled without errors.
However calling insarApp.py from console or in python calling import isce gives
No module named 'isce'

PRJ_SCONS_INSTALL is: /usr/local/isce-2.0.0_201604

I set my environment to:

export ISCE_HOME=/usr/local/isce-2.0.0_201604
export PATH=$ISCE_HOME/bin:$ISCE_HOME/applications:$PATH
export PYTHONPATH=/usr/local:$ISCE_HOME/applications:$ISCE_HOME/components

What am i doing wrong? According to the example of the answer before i would be setting:

export PYTHONPATH=/usr/local ??

Thanks for your help!

regards,
Andreas

RE: No module named 'isce' - Added by Scott Henderson over 4 years ago

Andreas,

Your paths are correct, but you should rename your install directory to simply 'isce' from 'isce-2.0.0_201604'. Or an easy way to fix is to create a symbolic link:
ln -s /usr/local/isce-2.0.0_201604 /usr/local/isce

isce is a python package, (folder of scripts containing init.py file). So insarApp.py tries 'import isce' but doesn't find it because of the folder name.

Sven,
I think everyone might have a slightly different approach for installing ISCE, but for what it's worth I have some notes for installing on Ubuntu here:
https://github.com/scottyhq/isce_notes

Scott

RE: No module named 'isce' - Added by Andreas Steinberg over 4 years ago

Very much obliged Scott!
Finally it works- now lets do some InSAR!

regards,
Andreas

RE: No module named 'isce' - Added by Mehdi Dar over 2 years ago

Dear all,
I installed the isce without problem (except the C header file for gdal was not found, but C++ header file for gdal was not found by scons while the installation procedure went ahead to the end.

After running the insarApp.py, I got no mudule isce error like the previous posts as follows:
rus@front-usr-433:~/ISCE/isce-2.1.0$ insarApp.py --steps
Traceback (most recent call last):
File "/home/rus/ISCE/isce-2.1.0/isce/applications/insarApp.py", line 31, in <module>
import isce
ModuleNotFoundError: No module named 'isce'

Here is my paths and environment variables (unzipped file isce-2.1.0: /home/rus/ISCE/isce-2.1.0):
PRJ_SCONS_BUILD = /home/rus/ISCE/isce-2.1.0/build
PRJ_SCONS_INSTALL = /home/rus/ISCE/isce-2.1.0/isce

export ISCE_ROOT=/home/rus/ISCE/isce-2.1.0
export ISCE_HOME=$ISCE_ROOT/isce
export PATH=$ISCE_HOME/bin:$ISCE_HOME/applications:$PATH
export PYTHONPATH=$ISCE_ROOT:$ISCE_HOME/applications:$ISCE_HOME/component

I tried to take above solutions into account, but those did not work for me. Thanks for any hint and help.
By the way, I am installing isce on UBUNTU 16.4 with GDAL 2.1.3.

Regards,
Mehdi

RE: No module named 'isce' - Added by Scott Henderson over 2 years ago

Hi Mehdi,

Your paths look correct. What output do you get if you type `echo $PYTHONPATH` in the terminal? Note that you have to export these paths every time you run isce (or put them in your .bashrc file so that every time you open a terminal they are run).

Also, run the following:

python
import sys
print(sys.path)

These are the paths that Python has access to (including PYTHONPATH)

Scott

(1-6/6)