Issue during ISCE Installation

Added by Shubham Awasthi about 2 years ago

Respected Sir,

I am trying to install ISCE 2.2.0 on my Linux mint 17.3 version, I am following the tutorials/guides given by you for this installation.-https://github.com/piyushrpt/oldLinuxSetup/blob/master/isceSetup.md

https://www.unavco.org/education/professional-development/short-courses/course-materials/insar/2016-insar-isce-giant-course-materials/Installation_instructions.pdf

but I am facing following problems installation

1)I am unable to find libXm.dylib and libXt.dylib hence not able to specify the paths for MOTIFLIBPATH ,X11LIBPATH, MOTIFINCPATH ,X11INCPATH

2)While preparing the configuration file I am facing the problem.
After giving the command vi SConfigISCE,
the VI editor opens, but it is not responding and not closing even after adding the final data for the configuration file(I am sending you the text copy of what I am putting in configuration file along this mail).

How to do that, I have tried for hours....

image.png
#Build Directory
PRJ_SCONS_BUILD =/home/snap/ISCE_install/build

#Install Directory (must end with isce)
PRJ_SCONS_INSTALL = /home/snap/ISCE_install/install/isce

LIBPATH = /home/snap/anaconda3/lib
CPPPATH = /home/snap/anaconda3/include /home/anaconda3/include/python3.6m /home/snap/anaconda3/lib/python3.6/site-packages/numpy/core/include /usr/include
FORTRANPATH = /home/snap/anaconda3/include /usr/include
FORTRAN = gfortran
CC = gcc

MOTIFLIBPATH = /usr/lib # path to libXm.dylib
X11LIBPATH = /usr/lib # path to libXt.dylib
MOTIFINCPATH = /usr/include # path to location of the Xm directory with various include files (.h)
X11INCPATH = /usr/include # path to location of the X11 directory with various include files

##If you want to enable cuda
ENABLE_CUDA = True

Untitled Document (823 Bytes)


Replies (2)

RE: Issue during ISCE Installation - Added by Piyush Agram about 2 years ago

.dylib is the extension for libraries on OSX. On linux, you should look for .so

There seems to be an inconsistency with CPPPATH for python3.6m.
You could use any other text editor that you are familiar with for preparing the config file. It doesn't have to be vi.

RE: Issue during ISCE Installation - Added by Jose Uribe about 2 years ago

I tried on Linux Mint 19, and you can use the following:

MOTIFLIBPATH = /usr/lib/x86_64-linux-gnu/
X11LIBPATH = /usr/lib/x86_64-linux-gnu/
MOTIFINCPATH = /usr/include/Xm
X11INCPATH = /usr/include/X11

You should find library files with extension *.so on Linux, *.dylib is for macOS. Try with:

sudo apt-get install libxm4 libmotif-dev libxt6

to install X11/Motif libraries.

(1-2/2)